Back to overview
Downtime

Services Unavailable

Feb 22, 2026 at 08:05am UTC
Affected services
EH Stats Dashboard
EH Stats Team-Panel
EH-Stats Bot

Resolved
Feb 24, 2026 at 12:51pm UTC

We were able to switch the dashboard online again. Thank you for your patience.

Updated
Feb 22, 2026 at 03:55pm UTC

The Bot is reachable again, the Dashboard will stay offline for internal Purposes. We apologise for any inconvenience this may cause you.

Created
Feb 22, 2026 at 08:05am UTC

Most of our Services are currently unavailable due to one of our Upstream provider having downtime.

Update: The Bot is online and woring again the dashboard will not be online for the next hours.